Slowness and intermittent issues with Mail and Drive

Incident Report for PreVeil

Resolved

The fix has been deployed and monitored. The incident is now resolved.
Posted Aug 14, 2026 - 15:10 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 14, 2026 - 12:46 EDT

Identified

The root cause issue has been identified and the team is working towards resolution.
Posted Aug 14, 2026 - 12:17 EDT

Investigating

We are currently investigating reports of slowness and intermittent issues on our backend infrastructure across services like Mail and Drive.
Posted Aug 14, 2026 - 11:48 EDT
This incident affected: Backend and AWS ec2-us-east-1.