API slowness

Incident Report for PreVeil

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 22:54 EST

Investigating

We are investigating an intermittent increase latency on our main backend API service. All file sharing, email and admin capabilities are affected and some API request might be slower than usual.
Posted Nov 19, 2025 - 17:04 EST
This incident affected: Mobile Apps (Android App, iOS App), Backend, Web PreVeil, and Desktop PreVeil (Admin Console, Drive, Key Menu, Mail).